最新の投稿

HKU\.Defaultはデフォルトユーザのものではない。

HKU\.DEFAULT(HKEY_USERS\.DEFAULT)は、あちこちで間違った認識をされている。HKU\.DEFAULT(HKEY_USERS\.DEFAULT)は、デフォルトユーザとかテンプレートユーザと呼ばれるアカウント(=今後作成されるユーザアカウントの初期設定)...

2006/09/01

gcc 3.4.6→4.1.1

GentooのemergeでGCC 4.1.x系が利用できるようになったので,
早速アップデート.

Gentoo Linux GCC Upgrade GuideどおりにやればOK
http://www.gentoo.org/doc/en/gcc-upgrading.xml

# emerge -u gcc
# gcc-config i686-pc-linux-gnu-4.1.1
# source /etc/profile
# fix_libtool_files.sh 3.4.6
# emerge --oneshot -av libtool
# emerge -e system
# emerge -e world
# emerge -aC =sys-devel/gcc-3.4*

途中, app-i18n/kccのコンパイルができなかった.
gcc 3.x系から発生している<varargs.h>が存在しない問題.
パッチに関しては, こちらを参照.

0 件のコメント:

コメントを投稿