最新の投稿

HKU\.Defaultはデフォルトユーザのものではない。

HKU\.DEFAULT(HKEY_USERS\.DEFAULT)は、あちこちで間違った認識をされている。HKU\.DEFAULT(HKEY_USERS\.DEFAULT)は、デフォルトユーザとかテンプレートユーザと呼ばれるアカウント(=今後作成されるユーザアカウントの初期設定)...

2006/01/23

dev-lang/php (is blocking dev-php/php-4.4.0-r4)

先日, dev-php/phpをdev-lang/phpに変更したら,
dev-php/PEAR-DBがdev-php/phpに依存しているようで,
emergeの際, 以下のメッセージが出るようになった.

dev-lang/php (is blocking dev-php/php-4.4.0-r4)

調べていくと, ちゃんと議論されていました.
http://readlist.com/lists/gentoo.org/gentoo-user/12/60240.html
http://readlist.com/lists/gentoo.org/gentoo-user/12/60093.html
とりあえず, dev-php/phpからdev-lang/phpへの変更をちゃんとやることに.
参考: http://www.gentoo.org/proj/en/php/php-upgrading.xml

先日の記事に加え, /etc/make.confのUSEに"cli pear xml"を追加して, emerge.

今のところ, Blockのメッセージは出ているが, 依存元のdev-php/PEAR-DBに
依存するmail-client/squirrelmailが, ちゃんと動いているようなので, しばらくは
これでもよしとする.

0 件のコメント: